You are not logged in.

Dear visitor, welcome to Dreamboard. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

  • "h.haberstroh" started this thread

Posts: 6

Location: Österreich

  • Send private message

1

Monday, December 27th 2010, 10:37am

Teletext (Videotext) funktioniert nicht mehr via WebControl

Seit [Moderator] Fremdimage, verstösst gegen die Boardregeln [/Moderator] (ist meines Wissens nah am CVS der DMM-Images) funktioniert der Teletext via Web-Interface (und damit z.B. auch DreamDroid) nicht mehr.
Genauer: Teletext lässt sich aktivieren und wird angezeigt, aber ab dann geht nichts mehr über das Web-Interfacce. Nur mehr mit der Fernbedienung kann man den Teletext bedienen und auch beenden.

Auch ein downgrade auf [Moderator] Fremdimage, verstösst gegen die Boardregeln [/Moderator] hilft nichts, denn dass dürfte durch das Upgrade auf die neuere Frontprozessor-Version bedingt sein. Da kann man nicht mehr zurück.

Gibt es andere (Tasten-)Codes für den Teletext? Bei der 7020 war das auch so.

Was kann ich tun, damit ich wieder über's Web alles der Box steuern kann?

Bis zum letzten Frontprozessor-Update hat Teletext auch über das WebIF funktioniert.

This post has been edited 2 times, last edit by "floh" (Dec 27th 2010, 12:01pm) with the following reason: Tippfehler in Überschrift


2

Monday, December 27th 2010, 11:24am

Falsches Image, sorry.
Grüße,
Olove

"All we need to do ... is keep talking (Stephen Hawking)"

Ich leiste KEINEN Support per PN/E-Mail, derartige Anfragen werden nicht beantwortet.
I won't give support via PN/E-Mail and I won't answer such messages.

3

Monday, December 27th 2010, 1:08pm

Seit [Moderator] Fremdimage, verstösst gegen die Boardregeln [/Moderator] (ist meines Wissens nah am CVS der DMM-Images) funktioniert der Teletext via Web-Interface (und damit z.B. auch DreamDroid) nicht mehr.
Genauer: Teletext lässt sich aktivieren und wird angezeigt, aber ab dann geht nichts mehr über das Web-Interfacce. Nur mehr mit der Fernbedienung kann man den Teletext bedienen und auch beenden.

Auch ein downgrade auf [Moderator] Fremdimage, verstösst gegen die Boardregeln [/Moderator] hilft nichts, denn dass dürfte durch das Upgrade auf die neuere Frontprozessor-Version bedingt sein. Da kann man nicht mehr zurück.

Gibt es andere (Tasten-)Codes für den Teletext? Bei der 7020 war das auch so.

Was kann ich tun, damit ich wieder über's Web alles der Box steuern kann?

Bis zum letzten Frontprozessor-Update hat Teletext auch über das WebIF funktioniert.
Spiel ein original DMM Image auf ,teste nochmal und meld dich wieder!

4

Monday, December 27th 2010, 2:12pm

Moin,

das ist auch so beim aktuellen original CVS. Videotext lässt sich per WebIF FB aktivieren und dann wars das.

Erinnert mit an die kabellose Dreamtastatur, bei dieser wurde es NIEMALS behoben.



Bye 321Berlin

OoZooN

Dreamer

    Germany

Posts: 2,002

Location: Wienhausen

Occupation: Elektriker

  • Send private message

5

Monday, December 27th 2010, 3:14pm

ack

sowohl mit webremote als auch mit dreamkeyboard lässt sich der videotext aufrufen aber nicht mehr beenden. das geht nur mit der fb.
mfg

OoZooN

Support für OoZooN Images gibt es auf forum.oozoon.de , nicht hier!

Two Beer or not two Beer, thats the Question

Aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

  • "h.haberstroh" started this thread

Posts: 6

Location: Österreich

  • Send private message

6

Tuesday, December 28th 2010, 7:35am

Teletext funktioniert nicht mehr via Web-Interface beim neuesten CVS-Image

Dass ich hier kein Fremdimage erwähnen sollte, habe ich verstanden (ist durch cut'n'paste entstanden), es tut mir Leid.
Aber Tatsache ist, dass der Teletext (Videotext) auch beim neuesten DMM-Image nicht mehr über das Web-Interface funktioniert. Demnach ist die Antwort "Sorry, falsches Image" überhaupt nicht hilfreich und kontraproduktiv (mehr als meine Erwähnung eines "bösen" Fremdimages, welches tatsächlich praktisch dem CVS-Image gleicht). Die Bestätigungen, dass das für Original-Images stimmt, sind produktiver - vielen Dank - , wenngleich sie mir nicht helfen aber meine Aussage bestärken.

Gibt es einen Workaround?
Wo könnte ich "Hand anlegen" (ich kann programmieren), um einen Workaround zu schaffen (der gesamte Quellcode ist ziemlich groß!)?
Wenn meine Beobqachtung stimmt (ein Bekannter hat das mit mehreren Boxen probiert), dass das erst nach dem nichtreversiblen Frontprozessor-Update auftritt, was kann man tun?
Kann man die Frontprozessor-Software downgraden?

Vielen Dank für eure Hilfe!

  • "h.haberstroh" started this thread

Posts: 6

Location: Österreich

  • Send private message

7

Tuesday, December 28th 2010, 2:19pm

Spiel ein original DMM Image auf ,teste nochmal und meld dich wieder!
Habe ich gemacht, habe mir ein Original-Image von http://dreamboxupdate.com/opendreambox/1.6/dm8000/images/ geholt, das vom 24.12.2010.
Das hat nichts am Verhalten geändert (außer dass ohne Alphacrypt meine SKY-Karte nicht mehr funktioniert - das ist das "Problem" mit Fremdimages):
Teletext lässt sich über WebRemote starten, aber nicht beenden und auch nicht steuern.

Vielleicht weiß jemand, wo das Problem zu suchen ist, oder vielleicht hat wer eine Idee für Workaround (ich kenn mich mit C, Python und Linux ein bisserl aus).

Vielen Dank!

8

Tuesday, December 28th 2010, 6:17pm

Das Problem kann ich mit der Firmware experimental-dm800se_20101224.nfi bestätigen.
Videotext läßt sich zwar via WebRemote starten, dann aber weder bedienen noch beenden. Beides geht dann nur über die Fernbedienung
1x Dreambox 800 HD se, 250 GB HDD, ohne LAN
1x Dreambox 800 HD se, 500 GB HDD, 100 Mbit Lan

This post has been edited 3 times, last edit by "Andy74" (Dec 28th 2010, 6:33pm)


  • "h.haberstroh" started this thread

Posts: 6

Location: Österreich

  • Send private message

9

Wednesday, December 29th 2010, 8:17pm

So, ich habe nun den Sourcecode vom Web-Interface aus einem Image von 2009, bei dem das sicher noch funktionierte mit jenem des aktuell(st)en Image verglichen. Des Senden der Keys wurde komplett umgestellt. Ich habe einfach die alte Methode mit einem kleinen Python-Script probiert. Damit kann man den Teletext wieder steuern. :D

Einen Fix für das aktuelle Web-Interface kann ich nicht bieten. Möglicherweise müsste man WebRemote in zwei Zuständen betreiben: "Normal" und "Im Teletext".

Die alte Methode funktioniert so:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
from struct import pack
from time import sleep
def sendkey(key):
    print "Send %d" % key
    dataon = pack('iiHHi', 0, 0, 1, key, 1)
    dataoff = pack('iiHHi', 0, 0, 1, key, 0)
    fp = open("/dev/input/event1", 'wb') # offensichtlich passt event1 und nicht event2
    fp.write(dataon)
    fp.write(dataoff)
    fp.close()

def test():
    sleep(5) # zum Fernseher gehen...
    sendkey(388) # Teletext
    sleep(5)
    for i in (4, 4, 4): # das sind die Tasten 3, 3, 3
    sendkey(i)
    sleep(10)
    sendkey(174) # Exit

test()

Die Codes habe ich aus dem WebRemote-Source-Code (einfach im Browser Source anzeigen lassen).

10

Saturday, December 17th 2011, 9:21am

Hallo, hat sich zu diesem Thema eigentlich bereits etwas getan? Ich würde gerne meine drei Dreamboxen
per LAN steuern und der Teletext sollte aber auch gehen. Ausserdem planen wir zukünftig auch in unseren
Entertainmentsystemen Dreamboxen einzusetzen und da steuern wir auch über LAN und der Teletext
wird wohl für viele auch wichtig sein.

Update: also mit dem aktuellen experimental Image funktioniert die Bedienung des Teletex per LAN auf
jedenfall immernoch nicht.

This post has been edited 1 times, last edit by "Gizzmo80" (Dec 17th 2011, 9:44am)