You are not logged in.

Dear visitor, welcome to Dreamboard. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, January 26th 2010, 8:06pm

GStream Plugin DV decoder zum Abspielen von DV Videos

Hallo zusammen,



ich wollte gerne heute einige Videos von meiner externen Festplatte schauen und bin auf folgendes Problem gestoßen:



Der Mediaplayer meldet "GStream Plugin Digital Video (DV) decoder not found"



Es handelt sich um .avi kodiert in DV - also direkt von der Videokamera auf die Platte gezogen und auf dem PC normal abspielbar.



gstreamer_0.10.25-r0_mipsel.ipk ist installiert. Das benötigte Plugin ist unter Dreamboxupdate nicht zu finden :(



Lediglich für ubuntu habe ich das plugin und eine libdv gefunden :( Kann mir jemand dabei helfen, dass ich meine Videos auf meiner neuen DM8000 ansehen kann?



Vielen Dank im voraus für jegliche Hilfe
Kein Schwanz ist so hart wie das Leben

2

Tuesday, January 26th 2010, 10:43pm

Hi,

ich sags ja nicht gerne. Aber das wird leider nichts werden. Alles was die Box abspielen kann, kann sie weil der Hardware Video Decoder diese Formate kann. Aber DV Video gehört nicht zu den Formaten die der Broadcom Chip abspielen kann. Und alleine in Software wird da nichts werden.

Die einzige Möglichkeit wäre diese Videos vorher auf dem PC in ein "brauchbares" Format umzuwandeln. Bevorzugt würde ich MPEG2 oder MPEG4 H264 nehmen. Zur not geht aber auch Divx bis zu einer Auflösung von 800x600.

cu

3

Wednesday, January 27th 2010, 1:20pm

Hallo,



danke für die Info - auch wenn das nicht gerade das ist, was ich mir gewünscht habe :(



Meine m2ts Dateien von meiner Sony Videokamera (sollte doch h.264 sein?) werden im Mediaplayer gar nicht erkannt. Gibt es dafür Abhilfe?
Kein Schwanz ist so hart wie das Leben

4

Wednesday, January 27th 2010, 1:24pm

Hi,

M2TS wird von unserem Multimediaframework momentan nicht sonderlich gut unterstützt (gstreamer). Ich weiss auch nicht ob und wann das mal damit besser funktionieren wird. Oder ob wir da mal einen eigenen decoder für bauen werden.

Von daher ist es momentan die beste Lösung ein normales TS draus zu machen. Am besten mit TSMuxxer. Sollte per google zu finden sein.

cu

5

Wednesday, January 27th 2010, 1:51pm

Danke, habe ich gefunden.

Ich habe natürlich gehofft um ein remuxxen rumzukommen.

Auf jeden Fall wäre eine geschmeidige Lösung auf der Box ein gewichtiges Kaufargument.

Ich persönlich würde mich freuen, wenn Ihr da eine eigene Lösung in Arbeit nehmen würdet.

Ich denke, mts/m2ts ist neben mkv das wichtigste Format für Videokameras. Und wenn ich ehrlich bin, hätte ich mir keine 8000 ansteller meiner 7025 hier hin gestellt, wenn ich damit nicht einen gewissen Nutzwert in Bezug auf mein HD Material verbunden hätte.

Nur um das schmale HD Sat Programm in GER anzuschauen, ist die Investition für eine 8000 viel zu hoch.
Kein Schwanz ist so hart wie das Leben

6

Thursday, January 28th 2010, 6:31pm

Nachdem ich nun alle Ratschläge beherzigt habe, laufen die HD Files als .ts anscheinend recht ordentlich.



Mit den .mp4 hapert es allerdings ganz gehörig :(



Die DV streams habe ich in h.264 .mp4 recodiert. Jetzt verfüge ich über hunderte von kleinen Schnipseln, die alle für sich einzeln abgespielt werden.



Ein Phänomen bringt mich zur Verzweiflung:



Wenn die Files in die Widergabeliste geladen werden und ich beginne 1 File abzuspielen, wird die Datei zwei mal abgespielt.

Ein mal mit Ton und ein mal ohne Ton.



Ein Wechsel von einer Datei zur Nächsten in der Wiedergabeliste findet nicht statt.



Das stellt momentan den absoluten Obergau dar, denn der mediaplayer spielt auch ein zusammengefügtes .mp4 nicht ordentlich ab.



Wie kann ich diese Klippe wohl noch umschiffen ohne meine letzten paar Haare zur raufen? ;)
Kein Schwanz ist so hart wie das Leben

7

Thursday, January 28th 2010, 6:40pm

Hi,

hmm was für ne Soft ist denn auf der Box drauf?

Aktuelles Release?

Also hmm das Problem sagt mir so jetzt nichts.

Die mp4's die ich hier hab laufen alle recht anständig.

cu

OoZooN

Dreamer

    Germany

Posts: 1,979

Location: Wienhausen

Occupation: Elektriker

  • Send private message

8

Thursday, January 28th 2010, 9:46pm

meine version vom 2.7.0 release
mfg

OoZooN

Support für OoZooN Images gibt es auf forum.oozoon.de , nicht hier!

Two Beer or not two Beer, thats the Question

Aktuelle Nachrichten rund um OoZooN-Images gibt es auf Twitter

9

Thursday, January 28th 2010, 10:12pm

Stimmt genau ;)



Ich habe heute Abend noch die große .mp4 mittels TSMuxxer in eine .ts gewandelt und die Datei ist ohne viel zu zicken durchgelaufen. Es handelt sich tatsächlich um die gleiche Datei.

Lediglich der Ton lief etwas nach wobei ich da die Ursprungsdatei heute auf dem PC nicht mehr geprüft habe.
Kein Schwanz ist so hart wie das Leben

This post has been edited 1 times, last edit by "meier2003" (Jan 28th 2010, 10:17pm)